monotone

Issue 85: automate tags outputs empty "branches" stanza

Reported by Thomas Keller, Oct 4, 2010

For some tags the "branches" stanza of automate tags keeps 
empty, for example when the branch certificates for the specific 
revisions are not pulled (and maybe also when the branches in 
question are suspended, but I haven't tested this).

The issue is here if this is valid basic_io syntax at all or if we 
shouldn't simply skip the "branches" stanza altogether 
when we have no branches to output...? The docs already note that 
the list is "possibly empty", but it still looks a bit 
fugly.

Comment 1 by Stephen Leake, Oct 8, 2010

Status: Duplicate

Comment 2 by Stephen Leake, Oct 8, 2010

Status: New

Created: 8 years 7 months ago by Thomas Keller

Updated: 8 years 7 months ago

Status: New

Followed by: 1 person

Labels:
Type:Defect
Component:Automation Interface
Priority:Medium

Quick Links:     www.monotone.ca    -     Downloads    -     Documentation    -     Wiki    -     Code Forge    -     Build Status