monotone on Debian

Issue 164: Debian monotone configure requires -lgmp for Botan

Reported by Stephen Leake, Apr 23, 2011

Steps to reproduce the problem:
1. uninstall libgmp-dev
2. install all packages listed in org.debian.monotone/control 
Build-Depends
3. cd net.venge.monotone
4. ./configure

Expected result:
successful configure

Actual result:
failed; config.log indicates 'can't find -lgmp'

Solution; add -libgmp-dev to org.debian.monotone/control 
Build-Depends

Comment 1 by Stephen Leake, Apr 23, 2011

This is on Debian testing.

Comment 2 by Stephen Leake, Apr 23, 2011

My Debian Maintainer skills are definitely rusty :(

First, this should have been reported on the Debian bug tracker.

Second, it's a bug in Botan packaging; libbotan1.8-dev should Depend 
on libgmp-dev.

On the other hand, 'reportbug' fails when I try to report a bug 
against libbotan1.8-dev, and 
http://packages.debian.org/sid/libbotan1.8 says it's a 'debports' 
package, which means it's not an 'official' Debian package? I'm 
confused.

Comment 3 by Stephen Leake, Apr 24, 2011

See Debian bug #623837; in wheezy, there is no problem with Botan in 
monotone configure.

Comment 4 by Markus Wanner, Mar 11, 2013

The Debian issue has been closed by Ondřej Surý on 2011-04-24.
Status: Fixed

Created: 9 years 5 months ago by Stephen Leake

Updated: 7 years 6 months ago

Status: Fixed

Followed by: 1 person

Labels:
Priority:Medium
Type:Defect

Quick Links:     www.monotone.ca    -     Downloads    -     Documentation    -     Wiki    -     Code Forge    -     Build Status