monotone

Issue 184: mtn writes packet data in wrong order...

Reported by Richard Levitte, Sep 12, 2011

The problem described here is illustrated by the packet attached to 
issue 182 (https://code.monotone.ca/p/monotone/issues/182/).  It's a 
packet like one might expect it, and it has the public key at the 
end...

Steps to reproduce the problem:
-------------------------------

1. mtn read botan-1.10.packet

Expected result:
----------------

mtn: läste 34 paket

Actual results:
---------------

mtn: fatal: error: wanted 1 rows got 0 in query: SELECT name FROM 
public_keys WHERE id = ?
mtn: This is almost certainly a bug in monotone.
mtn: Please report this error message, the output of 'mtn version 
--full',
mtn: and a description of what you were doing to '
https://code.monotone.ca/p/monotone/issues/'.
mtn: This error appears to have been triggered by something in the
mtn: database you were using, so please preserve it in case it can
mtn: help in finding the bug.
mtn: wrote debugging log to 
/home/levitte/monotonework/off.net/monotone/monotone/_MTN/debug
mtn: if reporting a bug, please include this file

Output of `mtn version --full`:
-------------------------------

monotone 1.0 (grundrevision: 
a7c3a1d9de1ba7a62c9dd9efee17252234bb502c)
Kör på               : Linux 3.0.0-1-686-pae #1 SMP Sat Aug 27 
16:41:03 UTC 2011 i686
C++-kompilator       : GNU C++ version 4.6.1 20110428 (prerelease)
C++-standardbibliotek: GNU libstdc++ version 20110428
Boost-version        : 1_46_1
SQLite-version       : 3.7.7 (kompilerad gentemot 3.7.6.2)
Lua-version          : Lua 5.1
PCRE-version         : 8.12 2011-01-15 (kompilerad gentemot 8.12)
Botan-version        : 1.8.12 (kompilerad gentemot 1.8.11)
Ändringar sen basrevisionen:
format_version "1"

new_manifest [b252820fde344fd3f5d023fd91de86522baa671d]

old_revision [a7c3a1d9de1ba7a62c9dd9efee17252234bb502c]

  Generated from data cached in the distribution;
  further changes may have been made.

Comment 1 by Richard Levitte, Sep 12, 2011

(appologies for showing the expected output in Swedish)

The problem was actually quite easy to fix in the packet file, just 
move the public key record from the bottom to the top.  However, 
this is something monotone should do itself, or at least as early as 
appropriate (before the first rdata or the first rcert that is 
signed with that key, basically).

Comment 2 by Richard Levitte, Sep 12, 2011

Never mind, I've misunderstood...
Status: Invalid

Created: 12 years 9 months ago by Richard Levitte

Updated: 12 years 9 months ago

Status: Invalid

Owner: Richard Levitte

Labels:
Type:Incorrect Behavior
Priority:Medium
Milestone:1.0

Quick Links:     www.monotone.ca    -     Downloads    -     Documentation    -     Wiki    -     Code Forge    -     Build Status