monotone

Issue 218: Several commands don't take --date-format option into account

Reported by Frédéric Praca, Oct 30, 2012

Steps to reproduce the problem:
-------------------------------

1. Pull the code from monotone repo
2. Run mtn --date-format '%Y-%m-%dT%H:%M:%S%z' automate certs 
b20a7c199ce2d223b1c86c23467ac9e7df43b2cf
3. or run mtn --date-format '%Y-%m-%dT%H%M%S%z' ls certs 
b20a7c199ce2d223b1c86c23467ac9e7df43b2cf

Expected result:
----------------
The result should take into account the format provided. In this 
case, adding the time zone as an offset.

Actual results:
---------------
Adding --date-format option changes nothing to the output.

Output of `mtn version --full`:
-------------------------------
monotone 1.0 (révision de base : 
a7c3a1d9de1ba7a62c9dd9efee17252234bb502c)
Exécuté sur               : Linux 3.2.0-32-generic #51-Ubuntu SMP 
Wed Sep 26 21:33:09 UTC 2012 x86_64
Compilateur C++           : GNU C++ version 4.6.1
Bibliothèque standard C++ : GNU libstdc++ version 20111019
Version de Boost          : 1_46_1
Version de SQLite         : 3.7.9 (compilé avec 3.7.7)
Version de Lua            : Lua 5.1
Version de PCRE           : 8.12 2011-01-15 (compilé avec 8.12)
Version de Botan          : 1.8.13 (compilé avec 1.8.13)
Changements depuis la rev. de base :
format_version "1"

new_manifest [b252820fde344fd3f5d023fd91de86522baa671d]

old_revision [a7c3a1d9de1ba7a62c9dd9efee17252234bb502c]

  Generated from data cached in the distribution;
  further changes may have been made.

Comment 1 by Frédéric Praca, Oct 31, 2012

Well, you'll find attached a dirty patch because I don't really know 
the whole Monotone architecture. So, it seems to be working but I 
feel it's dirty workaround ;)

Comment 2 by Frédéric Praca, Dec 5, 2012

Status: Started
Owner: fredpraca

Comment 3 by Frédéric Praca, Dec 5, 2012

Fixed in revision b34d9438297eda705f7e736983e2d7fdce46c394
Status: Fixed

Comment 4 by Frédéric Praca, Dec 6, 2012

Status: New

Comment 5 by Frédéric Praca, Dec 7, 2012

Status: Invalid

Comment 6 by Frédéric Praca, Dec 10, 2012

According to the thread on the mailing list (
http://lists.nongnu.org/archive/html/monotone-devel/2012-12/msg00023.
html )
Status: Accepted

Created: 5 years 19 days ago by Frédéric Praca

Updated: 4 years 11 months ago

Status: Accepted

Owner: Frédéric Praca

Labels:
Type:Defect
Priority:Medium

Quick Links:     www.monotone.ca    -     Downloads    -     Documentation    -     Wiki    -     Code Forge    -     Build Status